Back to overview
Downtime
OIer Space is unavailable
May 01 at 10:49pm CST
Affected services
oier.space
Resolved
May 02 at 12:09am CST
We paid the bill.
Affected services
Updated
May 02 at 12:00am CST
We figured out that the server of OIer Space provided by hkucloud.com is in arrears.
Affected services
Updated
May 01 at 11:21pm CST
We are investigating the cause of unavailability of OIer Space.
Affected services
Created
May 01 at 10:49pm CST
The incident has been reported.
Affected services